News

Dec 9th Servers Updated

### Important

- TeamSpeak Client 3.3.0 or later is needed to connect to this and upcoming server releases.

Powered by WHMCompleteSolution